LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 09-16-2012, 03:12 AM   #1
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Rep: Reputation: 25
issue with freebsd 9.1-RC1 when running "portupgrade -af"


Greetings to all,

I have been running in a VM (VMware Workstation 9: Host=win 7 Ultimate) Freebsd 9.1-RC-1 for about two months with no issues at all. I have X running as well with gnome2 for WM.
Today I though I would try to update my system
- First used cvsup
- Then ran "make fetchindex" ended up with yasr-0.6.9_2 being marked a broken because cannot build with new utmpx. This one seems to be known. Not worrying too much about it
- then ran "pkgdb -u"
- then "pkgdb -F"
- Then "portupgrade -af"
There is the big problem i cant seem to find a fix for it. Any help is much appreciated

Best

root@marcelain: portupgrade -af
"/usr/ports/Mk/bsd.linux-apps.mk", line 78: Malformed conditional (${LINUX_DIST_SUFFIX}=="")
"/usr/ports/Mk/bsd.linux-apps.mk", line 149: Malformed conditional (${LINUX_DIST_SUFFIX} == "-f10")
"/usr/ports/Mk/bsd.linux-apps.mk", line 172: Malformed conditional (${LINUX_DIST_SUFFIX} == "")
"/usr/ports/Mk/bsd.linux-apps.mk", line 425: Malformed conditional (${LINUX_DIST_SUFFIX} == "")
Error expanding embedded variable.
** Makefile possibly broken: graphics/linux-f10-cairo:
** Please report this to the maintainer for graphics/linux-f10-cairo
/usr/local/sbin/portupgrade:1540:in `get_pkgname': Makefile broken (MakefileBrokenError)
from /usr/local/sbin/portupgrade:632:in `main'
from /usr/local/sbin/portupgrade:616:in `each'
from /usr/local/sbin/portupgrade:616:in `main'
from /usr/local/sbin/portupgrade:590:in `catch'
from /usr/local/sbin/portupgrade:590:in `main'
from /usr/local/lib/ruby/1.8/optparse.rb:1310:in `call'
from /usr/local/lib/ruby/1.8/optparse.rb:1310:in `parse_in_order'
from /usr/local/lib/ruby/1.8/optparse.rb:1306:in `catch'
from /usr/local/lib/ruby/1.8/optparse.rb:1306:in `parse_in_order'
from /usr/local/lib/ruby/1.8/optparse.rb:1254:in `catch'
from /usr/local/lib/ruby/1.8/optparse.rb:1254:in `parse_in_order'
from /usr/local/lib/ruby/1.8/optparse.rb:1248:in `order!'
from /usr/local/lib/ruby/1.8/optparse.rb:1241:in `order'
from /usr/local/sbin/portupgrade:567:in `main'
from /usr/local/lib/ruby/1.8/optparse.rb:791:in `initialize'
from /usr/local/sbin/portupgrade:235:in `new'
from /usr/local/sbin/portupgrade:235:in `main'
from /usr/local/sbin/portupgrade:2304
 
Old 09-16-2012, 03:24 AM   #2
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
update

ran
# pkgdb -fF
# rm /var/db/pkg/pkgdb.db
# portupgrade -arRn
Broke at the same place as before with same error message.

Should I be reinstalling ?

Best
 
Old 09-16-2012, 06:23 AM   #3
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
Update final Solved

I seem to have solved the issue to my problems by modifying my make.conf file - Hope this can help others

Added two lines in my make.conf file

OVERRIDE_LINUX_NONBASE_PORTS=f10
OVERRIDE_LINUX_BASE_PORT=f10

With those two extra lines in make.conf file, system compiles with no issues after csup update.

Just another quick question

I type "uname -a" and still get "freebsd 9.1-RC1"
If I do "freebsd-update upgrade -r 9.1-RELEASE" i get a "failed" everytime.
As per release schedule (http://www.freebsd.org/releases/9.1R/schedule.html) the build has been made available the 14th of Septembre; or has it ?
So the question is how and when can i move to 9.1-release ?

Best
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"nmcli con" failed "Can't obtain connections: settings service is not running." parcox Slackware 2 08-14-2012 04:26 PM
How to set the font-size for "xterm" terminal-emulator (running "bash" shell) ajaygarg Linux - Desktop 1 03-09-2012 12:38 PM
Virt-Manager issue "please make sure libvirtd is running" chrisportela Linux - Server 2 07-08-2011 09:54 AM
"Keep laptop running on lid close?" + "ssh via crossover cable?" FatalKeystroke Linux - Laptop and Netbook 7 03-11-2011 07:53 AM
"Another power manager is already running" Xfce issue johnnyxxxcakes Linux - Newbie 3 06-25-2009 01:55 AM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration