LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Installing fusefs-kmod: "Set SRC_BASE if it is not in /usr/src" (http://www.linuxquestions.org/questions/%2Absd-17/installing-fusefs-kmod-set-src_base-if-it-is-not-in-usr-src-627393/)

odiseo77 03-11-2008 09:15 PM

Installing fusefs-kmod: "Set SRC_BASE if it is not in /usr/src"
 
Hello people, after some months, I'm giving FreeBSD a second try (FreeBSD 7.0, this time). My problem is, when I try to install fusefs-ntfs, I get the following error when checking for the fusefs-kmod dependency:

Inside /usr/ports/sysutils/fusefs-ntfs:
Code:

make install clean
(...)
===>  Installing for fusefs-ntfs-1.2216
===>  fusefs-ntfs-1.2216 depends on file: /usr/local/modules/fuse.ko - not found
===>    Verifying install for /usr/local/modules/fuse.ko in /usr/ports/sysutils/fusefs-kmod
===>  fusefs-kmod-0.3.9.p1.20080208 requires the userland sources to be installed. Set SRC_BASE if it is not in /usr/src.
*** Error code 1

Stop in /usr/ports/sysutils/fusefs-kmod.
*** Error code 1

Stop in /usr/ports/sysutils/fusefs-ntfs.
*** Error code 1

Stop in /usr/ports/sysutils/fusefs-ntfs.

I searched on google for this error and found tons of info about it. I installed the kernel source from the CD with sysinstall, attempted to reinstall the package and it failed with the same error. I also read some info on the net about a patch for the fusefs-kmod package Makefile, but I'm unsure about how to apply the patch (and I'm not sure if it works).

Additionally, I get this warning when the ntfs-3g dependency is being configured (previous to compiling process):

Code:

(...)
config.status: executing depfiles commands
****************************************************************************
* WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  *
* The FUSE user space binaries were NOT installed with root directory      *
* executable prefix. This means that automounting NTFS volumes during boot *
* could fail. This can be fixed the below way by reinstalling FUSE using  *
* the right 'configure' option during FUSE compilation:                    *
*      ./configure --exec-prefix=/                                        *
*      make && sudo make install                                          *
* WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  *
****************************************************************************
You can type now 'make' to build ntfs-3g.
===>  Building for fusefs-ntfs-1.2216
(...)

The issue I'm most concerned about is the first one, but this ntfs-3g issue is also important because I want my ntfs data partition to automatically mount during boot (and given the fact that the whole process is automated, I can't run the 'configure' script properly).

Does anyone know how to solve these two issues? Thanks in advance.

p3n1x 03-19-2008 12:53 PM

pull down the sources. csup your stable-source file
....quick run down


cp /usr/share/examples/cvsup/stable-supfile /root/stable-supfile


edit the /root/stable-supfile and put the cvsup site, and the release u want, like this

# listed at http://www.freebsd.org/doc/handbook/mirrors.html.
*default host=cvsup4.FreeBSD.org
*default base=/var/db
*default prefix=/usr
# The following line is for 6-stable. If you want 5-stable, 4-stable,
# 3-stable, or 2.2-stable, change to "RELENG_5", "RELENG_4", "RELENG_3",
# or "RELENG_2_2" respectively.
*default release=cvs tag=RELENG_7_0
*default delete use-rel-suffix

then, i simple type in csup -L 2 /root/stable-supfile

itll pull down all your sources

then try rebuilding the port

i never use the sysinstall to pull down sources...i have in the past, but i like doing it manually and knowing what its doing

odiseo77 03-26-2008 10:14 AM

Thanks, I'll try it when I reinstall FreeBSD in some days (I removed it in order to install it on the first partition of my second HD). I'll let you know how it goes.

holms 10-09-2008 06:02 AM

big big thnx for this manual, you saved my time =)

CodeBlock 07-13-2009 10:22 AM

Sorry to dig up an old post, but I had this same problem and did what p3n1x said, and now I'm wondering how to delete the sources to get that hard drive space back. It installed sources for *everything* gcc, gdb, etc.. and I'd like to get that space back.

I'm new to freebsd so... please go gentle on me.

Thanks a lot.

anomie 07-14-2009 05:33 PM

Assuming /usr/src is really the culprit that's eating up your disk space...

# cd /usr/src && make cleanworld

If that doesn't free up enough space, you can delete /usr/src/*. (You'll have to csup again, though, if you need the source for anything later.)


All times are GMT -5. The time now is 04:28 PM.