LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices



Reply
 
Search this Thread
Old 10-08-2004, 06:02 AM   #1
Ninja_212
Member
 
Registered: Sep 2003
Location: Indonesia
Distribution: Mandrake,RedHat,Slackware
Posts: 58

Rep: Reputation: 15
How to give cdrom access for user & can i mount FAT32 partition atomatically on boot?


Dude.. please tell me how to mount FAT32 partition automatically, cause i thought it would be just the same like Linux. And can i give user's access to cdrom, i've already tried to give the "users" option in fstab but it failed.

I am a Linux user and this is my first time trying FreeBSD....

I'am really need your help guys...Thank's

..Sorry about my english...english is not my native language..
 
Old 10-08-2004, 07:47 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
for the cd-rom, use this type of fstab-line (of course with your own node names and mount points):

/dev/cdroms/cdrom0 /mnt/cd iso9660 user,noauto,unhide 0 0

make sure options include "user" but no "ro". then, for the windows fat32 drive:

/dev/discs/disc0/part1 /mnt/hda1 auto defaults 0 2

fstab entry. part1 is the partition, hda1 is the mountpoint, defaults might do or then give it somekind of options like "users"...that ought to do.

EDIT: looks like my fat32-drive has the type of "auto" which might be better to be set to "vfat"...like this:

/dev/discs/disc0/part1 /mnt/hda1 vfat defaults 0 2

auto works too (it works on my machine) but why not use "vfat" when it means fat-drive also, because I don't have the "user" in the options, I can only mount that drive as root. that suits me well...but not for you necessarily.

Last edited by b0uncer; 10-08-2004 at 07:49 AM.
 
Old 10-08-2004, 09:15 PM   #3
-X-
Member
 
Registered: Oct 2003
Location: Tx,USA
Distribution: Slackware, Red Hat, CentOS
Posts: 495

Rep: Reputation: 30
Don't think FreeBSD supports 'user'. It's a Linux thing.

The user has to own the mount, so either change the owner and group for /mnt/cdrom to whoever or do it the BSD way and mkdir ~/cdrom, ~/windows.

fstab looks something like;
/dev/acd0 /home/<user>/cdrom cd9660 ro,noauto 0 0
/dev/ad0s2 /home/<user>/fat msdos rw,auto 0 0

or make user own /mnt/cdrom and /mnt/fat and replace the /home.... mount point above.
 
Old 03-09-2005, 04:01 PM   #4
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Thanks for that, it had me running in circles!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
mount partition and give access Lipchitz Linux - General 1 04-05-2005 11:36 PM
give user access to mount xbriank Fedora 2 02-15-2005 07:44 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
Unresolved : Cannot access cdrom mount from any user except root??? acadcworks Linux - General 5 10-18-2002 12:08 PM


All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration