LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 11-06-2009, 10:28 AM   #1
toledano
LQ Newbie
 
Registered: Dec 2008
Posts: 24

Rep: Reputation: 15
How to disable pc speaker in openBSD?


hi,

I just installed openBSD on my laptop.
how do i disable the pcspeaker without the GUI?
thanks,

danny.
 
Old 11-06-2009, 12:11 PM   #2
ocicat
Member
 
Registered: May 2007
Posts: 207

Rep: Reputation: 46
Quote:
Originally Posted by toledano View Post
how do i disable the pcspeaker without the GUI?
Study Section 5.9 of the FAQ:

http://openbsd.org/faq/faq5.html#BootConfig

...as this explains how drivers can be disabled. Of course, you will also need to study the output of dmesg(8) to find what driver is associated with your speaker.
 
Old 11-06-2009, 01:23 PM   #3
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by toledano View Post
hi,

I just installed openBSD on my laptop.
how do i disable the pcspeaker without the GUI?
thanks,

danny.
I did this on Linux...it may work on BSD

Code:
root@host# rmmod pcspkr
-C
 
Old 11-06-2009, 01:27 PM   #4
ocicat
Member
 
Registered: May 2007
Posts: 207

Rep: Reputation: 46
Quote:
Originally Posted by custangro View Post
I did this on Linux...it may work on BSD
It won't. OpenBSD does not have a rmmod command.
 
Old 11-06-2009, 05:26 PM   #5
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by ocicat View Post
It won't. OpenBSD does not have a rmmod command.
Well then I'm all out of ideas
 
Old 11-08-2009, 02:23 PM   #6
toledano
LQ Newbie
 
Registered: Dec 2008
Posts: 24

Original Poster
Rep: Reputation: 15
hi,

by using the dmesg I see:
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0

I used the command "sudo config -e /bsd" (and also "sudo config -e -u -o bsd.new /bsd")
and disabled midi,spkr and pcppi(i am not sure which one to disable so I disabled all).
the pc speaker still works..
what else could I try?
 
Old 11-09-2009, 01:23 PM   #7
ocicat
Member
 
Registered: May 2007
Posts: 207

Rep: Reputation: 46
Quote:
Originally Posted by toledano View Post
the pc speaker still works..
what else could I try?
Given that this is turning into a fishing expedition, you may want to made a copy of /bsd which has not been altered. Although I don't see that the disabling the drivers discussed may be problematic later, it is good to have the insurance that you can easily return to a default configuration if necessary.

In the dmesg(8) output, I suspect you will also see audio(4) drivers listed. You may want to disable all of these as well.

If this does not disable speaker output, you will need to post the output of dmesg(8). The drivers discussed thus far are generic, but without knowledge of your exact hardware, I will not be able to help you further.
 
Old 11-10-2009, 05:08 PM   #8
GazL
Senior Member
 
Registered: May 2008
Posts: 3,391

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Is "mixerctl outputs.spkr_mute=on" not suitable?
 
Old 11-10-2009, 05:09 PM   #9
bigearsbilly
Senior Member
 
Registered: Mar 2004
Location: england
Distribution: FreeBSD, Debian, Mint, Puppy
Posts: 3,287

Rep: Reputation: 173Reputation: 173
wirecutters?

:-)

why?

X: xset -b
vim: set visualbell

personally I love morse -p

Last edited by bigearsbilly; 11-10-2009 at 05:11 PM.
 
Old 11-10-2009, 07:52 PM   #10
ocicat
Member
 
Registered: May 2007
Posts: 207

Rep: Reputation: 46
Quote:
Originally Posted by GazL View Post
Is "mixerctl outputs.spkr_mute=on" not suitable?
This is actually a good question to raise.

I guess I had dismissed this in my own mind is because some beeps go directly to the speaker; somehow the audio subsystem is bypassed, but I may be vaguely recalling hardware-specific information. I don't routinely gut the system.

But the OP should try this suggestion. It may very well be a viable answer for the hardware used.
 
Old 11-11-2009, 01:25 AM   #11
toledano
LQ Newbie
 
Registered: Dec 2008
Posts: 24

Original Poster
Rep: Reputation: 15
hey,

@GazL : you are half right thanks for the suggestion.
@ocicat : thanks for your help.

the command : "mixerctl inputs.spkr.mute=on" WORKS!
 
Old 11-11-2009, 03:35 AM   #12
GazL
Senior Member
 
Registered: May 2008
Posts: 3,391

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Quote:
Originally Posted by toledano View Post
@GazL : you are half right thanks for the suggestion.
the command : "mixerctl inputs.spkr.mute=on" WORKS!
You're welcome. My hardware doesn't create mixerctl entries under inputs for spkr only under outputs. Sounds (forgive the pun) like your sound hardware is layed out differently to mine.

Anyway, Glad you resolved it.
 
Old 12-17-2009, 12:18 AM   #13
ofaring
Member
 
Registered: Feb 2006
Location: Ontario, Canada
Distribution: Debian, sometimes BSD.
Posts: 44
Blog Entries: 13

Rep: Reputation: 21
Old topic, but I couldn't resist. Using the mixer/mute option gets the job done, unless you want your pc speaker (sometimes a tiny speaker on the motherboard as opposed to the audio speakers) to give notice of other things. For instance, on my laptop I get a nice beeping to warn me when my battery is at 3%. And since I'm running Fluxbox with a minimum of glitter, that's handy.

So, in either your ~/.xinitrc (if you start X with the "startx" command), or your ~/.fluxbox/startup (there are other ways), add what was mentioned above:
Code:
xset -b
That takes care of beeping in X terminals. And for the console...

Edit /etc/wsconsctl.conf and make sure that you have this:
Code:
keyboard.bell.volume=0
Gotta love the quiet.
 
Old 01-26-2010, 10:10 AM   #14
rndm_luser
LQ Newbie
 
Registered: Jan 2009
Posts: 8

Rep: Reputation: 1
Just for reference, to disable the console bell on NetBSD you can put the following in /etc/wscons.conf:
Code:
setvar wskbd bell.pitch 0
 
  


Reply

Tags
configuring, openbsd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable PC Speaker Toods Slackware 12 11-02-2007 12:04 PM
How could I make USB speaker as default/master speaker ? czy11421 Linux - Hardware 1 09-02-2007 10:59 AM
Disable SSHv1 (OpenBSD) JF1980 *BSD 4 07-12-2007 12:48 PM
Disable PC Speaker iXneonXi DamnSmallLinux 4 03-16-2007 05:58 AM
disable motherboard speaker? newuser455 Linux - Hardware 3 07-27-2005 02:23 AM


All times are GMT -5. The time now is 09:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration