LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 10-16-2007, 08:00 PM   #1
bpalmer
Member
 
Registered: Mar 2005
Distribution: Debian stable, OpenBSD, FreeBSD
Posts: 30

Rep: Reputation: 15
freebsd stable: only ancient software?


Hi,

I just installed FreeBSD (again). Got everything working properly except for my Atheros-based wifi card, but I don't care about that at the moment. Gnome is pretty fast. Nvidia's drivers seem to be working well.

However, it worries me that FreeBSD has Firefox 1.5 and GAIM 1.5 in the stable branch. These two programs are a year and a half old! Debian Linux's stable branch is considered by many to be extremely out of date, and even *it* had Firefox 2 and GAIM 2 a year ago.

How does one run a secure, stable FreeBSD system without such ancient software? I'd like at least Firefox 2 and GAIM 2.

I've had extremely bad luck with using ports, so I'd rather consult with other people before breaking my entire system again.

Thanks!
 
Old 10-17-2007, 05:32 AM   #2
reverse
Member
 
Registered: Apr 2007
Distribution: Gentoo
Posts: 337

Rep: Reputation: 30
:-/ 1st of all: Ancient? Ha!
2nd of all: Did you install firefox from ports? Because, unless the freebsd website is telling me lies.. /usr/ports/www/firefox should give you FF 2.0 *and* /usr/ports/www/firefox-devel should give you FF 3.
 
Old 10-17-2007, 09:21 AM   #3
bpalmer
Member
 
Registered: Mar 2005
Distribution: Debian stable, OpenBSD, FreeBSD
Posts: 30

Original Poster
Rep: Reputation: 15
So basically, I use cvsup or portwhatever to grab the latest snapshot of ports, and build it from there?

Don't I have to also build a new kernel to match the snapshot, or is mixing my 6.2 stable GENERIC kernel with bleeding-edge ports acceptable? I don't understand how this is supposed to work, and I can't find any documentation explaining it.

I even bought a book on FreeBSD a few months ago and it doesn't even explain it!
 
Old 10-17-2007, 11:14 AM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Read here: http://www.freebsd.org/doc/en_US.ISO...rts-using.html

Follow that, except what I'd personally recommend is:
  • Instead of cvsup, use csup (which is part of the base system, as of 6.2, IIRC).
  • Instead of portupgrade, use portmaster (which uses tools provided in the base system).
 
Old 10-17-2007, 11:20 AM   #5
reverse
Member
 
Registered: Apr 2007
Distribution: Gentoo
Posts: 337

Rep: Reputation: 30
Tried reading the FreeBSD Handbook? It's a pretty good piece of documentation and it's available online, for free. See FreeBSD.org
 
Old 10-17-2007, 11:52 AM   #6
p3n1x
LQ Newbie
 
Registered: Aug 2002
Distribution: FreeBSD
Posts: 24

Rep: Reputation: 15
yes

use csup -L 2 ports-supfile

or

portsnap fetch extract update

please read the handbook section documenting ports, how to install, how to update ports, and how to keep the ports tree in sync

specifically here

http://www.freebsd.org/doc/en_US.ISO...rts-using.html
 
Old 10-17-2007, 12:57 PM   #7
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Code:
# export PACKAGESITE='ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Latest/'
# pkg_add -r firefox
 
Old 10-17-2007, 07:05 PM   #8
bpalmer
Member
 
Registered: Mar 2005
Distribution: Debian stable, OpenBSD, FreeBSD
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by vermaden View Post
Code:
# export PACKAGESITE='ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Latest/'
# pkg_add -r firefox
Code:
pkg_add: package 'firefox-1.5.0.8,1' or its older version already installed
pkg_add: 1 package addition(s) failed
pkg_delete won't let me remove Firefox 1.5 either, since it's a dependency of Gnome and some other stuff. Am I supposed to just feed pkg_add the -F flag?

(This is after pkg_add froze my machine, requiring a hard reboot, and also corrupted my filesystem. :P)

So, packages-6-stable/Latest/ is the latest SECURE software available for FreeBSD? I didn't see anything in the documentation explaining the differences between release, stable, etc.

I've already read through 90% of the manual, since the text in the book I have is pretty much an exact copy. The ports page is ok, but it didn't explain what I wanted to know: that is, whether or not it's ok to mix to your GENERIC kernel with more modern ports, and what the differences between the releases are.

Thanks for the replies. I'm a FreeBSD idiot.

Last edited by bpalmer; 10-17-2007 at 07:07 PM.
 
Old 10-17-2007, 08:31 PM   #9
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by bpalmer
The ports page is ok, but it didn't explain what I wanted to know: that is, whether or not it's ok to mix to your GENERIC kernel with more modern ports
Yes. Whether you're running the GENERIC kernel has nothing to do with updating your ports.
 
Old 10-17-2007, 08:54 PM   #10
bpalmer
Member
 
Registered: Mar 2005
Distribution: Debian stable, OpenBSD, FreeBSD
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by anomie View Post
Yes. Whether you're running the GENERIC kernel has nothing to do with updating your ports.
Great!

And one final question I don't see an answer to in the documentation: what should I put for the "tag" in my supfile if I want the latest STABLE ports?

It has "*default release=cvs tag=." by default, which is the bleeding-edge current ports. Is there a page that has a list of the available tags?
 
Old 10-17-2007, 10:08 PM   #11
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
There is just one ports tree. Use: *default release=cvs tag=.

I wouldn't go so far as to call them "bleeding-edge"; my experience has been that breakage among ports is extremely rare (and usually means you didn't read /usr/ports/UPDATING).
 
Old 10-17-2007, 10:43 PM   #12
bpalmer
Member
 
Registered: Mar 2005
Distribution: Debian stable, OpenBSD, FreeBSD
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by anomie View Post
There is just one ports tree. Use: *default release=cvs tag=.

I wouldn't go so far as to call them "bleeding-edge"; my experience has been that breakage among ports is extremely rare (and usually means you didn't read /usr/ports/UPDATING).
Awesome!

Thanks a lot for the help everyone!
 
Old 10-18-2007, 05:58 AM   #13
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Quote:
Originally Posted by bpalmer View Post
Code:
pkg_add: package 'firefox-1.5.0.8,1' or its older version already installed
pkg_add: 1 package addition(s) failed
pkg_delete won't let me remove Firefox 1.5 either, since it's a dependency of Gnome and some other stuff. Am I supposed to just feed pkg_add the -F flag?
Code:
# export PACKAGESITE='ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Latest/'
# pkg_delete -f -x firefox
# pkg_add -r firefox
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Which version of FreeBSD is most stable? General *BSD 3 03-07-2007 02:37 PM
LXer: My desktop OS: FreeBSD 6.0-STABLE LXer Syndicated Linux News 0 04-26-2006 07:54 AM
freebsd 4.7 howto upgrate stable kernelvn *BSD 0 06-20-2005 10:32 AM
FreeBSD Making my Software stable MA_D *BSD 4 04-18-2005 09:14 AM
FreeBSD 4.10-STABLE vs. 5.2.1-CURRENT entob *BSD 3 09-01-2004 03:30 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 05:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration