LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 03-25-2007, 07:47 PM   #1
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Rep: Reputation: 15
FreeBSD Mouse Problem - Tried Everything ... Please Help.


Ok, this is attempt two at posting...

Just installed FreeBSD 6 on my laptop.

No mouse pointer at all using the trackpad.

Have tried endless combinations of settings in rc.conf and my xorg.conf file ...

I have turned moused OFF as im less fussed about a mouse on the command line but do want one for X. I read this on another thread which said that X will use its own mouse driver so sorry if this is wrong!


Firstly, WHERE SHOULD xorg.conf go?

In

/etc/X11/xorg.conf

Or

/usr/X11R6/lib/X11/xorg.conf


Also should it be called xorg.conf or xorg.conf.eg ?


This is my pointer section in xorg.conf

Code:
Section "InputDevice"

    Identifier	"Mouse0"
    Driver	"mouse"
    Option	"Device"	"/dev/sysmouse"
    Option	"Protocol"	"Auto"

EndSection

I have this in rc.conf (I commented the moused lines out to disable it).

Code:
usbd_enable="YES"
gdm_enable="YES"
# -- sysinstall generated deltas -- # Sat Mar 24 13:47:06 2007
#moused_flags=""
#moused_port="/dev/sysmouse"
#moused_type="auto"
#moused_enable="YES"

Also for the record, a dmesg says that I have something mouselike at psm0.

Code:
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model GlidePoint, device ID 0

Also, I only have psm0 and sysmouse in /dev (there is other stuff, but these are the only vaguely mousey things to be found there ... )

I have read the FreeBSD guides and numerous posts, and could really use a some guidance on this ...


Thanks.


Max.
 
Old 03-26-2007, 06:33 PM   #2
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Rep: Reputation: 30
Hello,

First, the file should be /etc/X11/xorg.conf

Second, it looks like the mouse settings may not be right in the device section of xorg.conf. Did you try to run xorgconfig? There should be listings for various mouse settings, like setting up for the touchpad of a laptop.
 
Old 03-26-2007, 07:45 PM   #3
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
try reconfiguring Xorg and check if your mouse is working from a tty(if not use sysinstall to correct it). To configure the X11 server use
Code:
X -configure
while not running X.
 
Old 03-27-2007, 06:09 PM   #4
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
Thankyou,

I will do this tomorrow when I am back at my machine.

The trouble with running xorg config is that I do not have the exact monitor details for the laptop (it was given to me without any manuals).

I will try and copy out the details in that file and supply these to the configure utility.


Stay tuned and will post my results.


Thanks for helping.
 
Old 03-28-2007, 06:41 AM   #5
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Rep: Reputation: 31
So you really haven't tried everything, have you?
 
Old 03-29-2007, 05:38 PM   #6
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
Excuse me?
 
Old 03-30-2007, 07:39 AM   #7
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Rep: Reputation: 31
The title of this thread is " FreeBSD Mouse Problem - Tried Everything ... Please Help."
 
Old 03-30-2007, 08:01 AM   #8
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
..........

Last edited by maxvonseibold; 03-31-2007 at 05:07 AM.
 
Old 03-30-2007, 11:07 AM   #9
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 397

Rep: Reputation: 81
Quote:
Originally Posted by maxvonseibold
Unless ofcourse you do know the HorizSync and VertRefresh rates for a Sony Vaio PCG-Z600NEK Laptop in which case thank you so much for your kind assistance .....
these should work:
Code:
HorizSync	30 - 57
VertRefresh	30 - 72
or
Code:
HorizSync   31.5 - 48.5
VertRefresh       60
Also maybe this page will help You:
http://www.bodgit-n-scarper.com/sony.html

You should also check these:
http://tuxmobil.org/sony.html
http://www.linux-on-laptops.com/sony.html
 
Old 03-30-2007, 01:32 PM   #10
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
hmmmm ok.


Lots of stuff. First up thank you vermaden for the monitor information.

I checked out the links you posted and then ran xorgcfg -textmode as suggested by

http://www.freebsd.org/doc/en_US.ISO...book/book.html

This seemed a logical approach to take ....

Once this was done and I entered the monitor specs kindly provided and did:

Xorg -config /etc/X11/xorg.conf (where xorg.conf was the output of xorgcfg).

I got a Fatal Screens Error:
no screens found.

I checked the log files from Xorg.0.log and changed the driver from 'ati' to neomagic and reran Xorg -config.

I got the basic black and grey grid with the mouse pointer represented as a big grey square that would not move ... is this an improvement ... ? ;-)


I sorted the square problem by adding this:

Option "SWCursor"
Option "NoRenderExtension"

To the Device section of the conf file.

Any ideas what next? I specified the mouse as a Glidepoint.

Here is the xorg.conf file again ...


Code:
Section "ServerLayout"
	Identifier     "Layout0"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
	Load "freetype"
	# Load "xtt"
	Load  "extmod"
	Load  "glx"
	Load  "dri"
	Load  "dbe"
	Load  "record"
	Load  "xtrap"
	Load  "type1"
	Load  "speedo"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "GlidePoint"
	Option	    "Device" "/dev/sysmouse"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc101"
	Option	    "XkbLayout" "gb"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
 ### Comment all HorizSync and VertSync values to use DDC:
	HorizSync    31.5 - 48.5
	VertRefresh  60.0 - 60.0
EndSection

Section "Device"
	Identifier  "Card0"
#	Driver      "ati"
	Driver      "neomagic"
	Option 	    "SWCursor"
	Option	    "NoRendorExtension"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option     "HWCursor"  "Off"
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768"
	EndSubSection
EndSection
So to recap...

gdm is starting a pretty blue screen (Xorg is alive).
I still have no mouse .....


Any clues?


Thank You.


p.s. introuble. If you have read this far please do not bother posting anything, just go away.
 
Old 03-30-2007, 01:50 PM   #11
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
Also thought I would add this:

My /etc/rc.conf file has the following:

moused_flags=""
moused_port="/dev/sysmouse"
moused_type="SysMouse"
moused_enable="YES"

I ran /usr/sbin/sysinstall

and specifying the pointer as a Glidepoint made the test app break, and this utility insisted that

moused_port="/dev/psm0"
moused_type="auto"
moused_enable="YES"

Was the setup I need (despite a lot of posts saying to contrary) ...


More confusion ...
 
Old 03-30-2007, 02:12 PM   #12
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
I fixed it ...

Last edited by maxvonseibold; 03-30-2007 at 02:17 PM.
 
Old 03-30-2007, 02:16 PM   #13
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
I fixed it ...

Turned off moused (by commenting out all moused lines in rc.conf) and just let Xorg run its mouse.

Specified

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psm0"
EndSection

Section "Device"
Identifier "Card0"
# Driver "ati"
Driver "neomagic"
Option "SWCursor" #This option deals with the big gray square cursor problem.
Option "NoRendorExtension" #This option deals with the big gray square cursor problem.
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
Option "HWCursor" "Off"
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768"
EndSubSection
EndSection


Thanks to everyone (except the sarcastic idiot).
 
Old 03-31-2007, 02:29 AM   #14
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Rep: Reputation: 31
I've made a perfectly valid statement. I didn't help you and it's my right to do so.

Quote:
not that it is any of your concern seeing that your sole purpose so far is to cause trouble.
That's kind of a hypocritical statement .. the idea under which you've posted this thread is that it should be someone else's concern, not just yours.

I had intended my reply as a joke .. *had* .. before you took it seriously. So now I'm taking it seriously.
 
Old 03-31-2007, 05:25 AM   #15
maxvonseibold
Member
 
Registered: Mar 2006
Location: Oxford, UK.
Distribution: Debian, Ubuntu, RHEL5, OSX
Posts: 41

Original Poster
Rep: Reputation: 15
A joke eh?

I love the way people always use that phrase to excuse anything. It goes hand in hand with religion as the ultimate get out clause for anything. It was not a joke, it was rude. I spent a lot of time and trouble trying to figure my problem out and figured I would ask. Your reply was frankly very annoying.

Your an odd fellow, looking at my post and taking little pot shots here and there for no real reason. A bit sad, considering your other posts seem pretty interesting.

Still, do what ever you want to do.
 
  


Reply

Tags
as, big, displays, freebsd, mouse, pointer, sony, square, vaio, xorgconf, z600


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB mouse for Freebsd 6.0 Keruskerfuerst *BSD 3 01-30-2006 06:08 PM
mouse problems with FreeBSD asilentmurmur *BSD 3 10-22-2005 06:46 PM
FreeBSD usb mouse + mount problem scottman *BSD 6 04-11-2005 11:18 PM
mouse problem with FreeBSD 5.2.1/ KDE 3.1/ XF86 4.4.0 deesto *BSD 2 09-10-2004 10:03 PM
FreeBSD mouse is sketchy php *BSD 2 12-06-2002 01:11 PM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration