LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   editing ~/.vimrc in FreeBSD (http://www.linuxquestions.org/questions/%2Absd-17/editing-%7E-vimrc-in-freebsd-730290/)

jus71n742 06-02-2009 10:24 PM

editing ~/.vimrc in FreeBSD
 
I have made it to the file but I am wondering what to do in order to create syntax highlighting. I have added the line
Code:

syntax on
and this has done nothing. I am also running in just TTY1-6
could this be a reason?

thanks

Ygrex 06-03-2009 04:21 AM

does ":syntax on" work when you type it in vim interactively?

jus71n742 06-03-2009 09:46 AM

Quote:

Originally Posted by Ygrex (Post 3561353)
does ":syntax on" work when you type it in vim interactively?

No, course I was also noticing that I may not have the full version...and one thing that is annoying me is I can not find the way to, for example in Linux
Code:

sudo apt-get install vim-full
and VIM is installed. I can't find what does this in FreeBSD, and I think that may have some bearing in this situation.

rsciw 06-03-2009 10:31 AM

this should be the full vim:
http://ftp2.at.freebsd.org/pub/FreeB...-7.2.166_1.tbz

compared to
vim-lite-7.2.166_1.tbz

does freebsd give you options what to install when you use
pkg_add -i vim
?

vim syntax highlighting:
http://www.vim.org/htmldoc/syntax.html

basically to enable it, it's
:syntax enable

Fin7PL 06-03-2009 12:25 PM

These are directly from the very useful handbook Press Previous to package method :-) (2 methods: Package method and port method)

http://www.freebsd.org/doc/en/books/...rts-using.html

You can use
Code:

pkg_add -r vim
or then if you have ports tree installed (if not you can get it by)

Code:

portsnap fetch
portsnap extract

If you have portstree you can update it by running

Code:

portsnap fetch
portsnap update


then

goto /usr/ports/editors/vim

Code:

make install clean
This might also require X on its depencies so if you want it without X

if you dont have X installed then i dunno this is a little old article

http://www.tequilafish.com/2005/08/1...out-x-windows/

jus71n742 06-03-2009 06:22 PM

error: FTP Unable to get ftp://ftp.freebsd.org/etc etc etc No address record.
pkg_add: unable to fetch 'ftp://ftp."""" by URL

jus71n742 06-03-2009 08:46 PM

seems as though I don't have any internet connection....

Fin7PL 06-04-2009 01:08 AM

Tried the ports method?

You really have no connectivity to anything in there?

ifconfig?

Btw how old your FreeBSD is?

if its VERY old then

http://lessfaq.wordpress.com/2008/05...ecord-freebsd/

But i dont think that is the case..

Is DNS working (etc/resolv.conf)?

output of
Code:

host ftp.freebsd.org
cat /etc/resolv.conf

Suppose you have no firewall installed/enabled?

jus71n742 06-05-2009 12:09 AM

Quote:

Originally Posted by Fin7PL (Post 3562506)
Tried the ports method?

You really have no connectivity to anything in there?

ifconfig?

Btw how old your FreeBSD is?

if its VERY old then

http://lessfaq.wordpress.com/2008/05...ecord-freebsd/

But i dont think that is the case..

Is DNS working (etc/resolv.conf)?

output of
Code:

host ftp.freebsd.org
cat /etc/resolv.conf

Suppose you have no firewall installed/enabled?

No No its FreeBSD 7.2, I ran ifconfig and best I could see was it was at least connecting. It showed the ethernet as enabled and active. and inet is shown as home IP (127.0.0.1)

so I am pretty confused right now.

Fin7PL 06-05-2009 03:09 AM

Seems like you have only the loopback device there (lo0)

Could you post the output of
Code:

ifconfig
also have you done anything to the kernel. What network card /chip you have?

Also if you kindly would post what says
Code:

dmesg

jus71n742 06-07-2009 08:21 PM

$ ifconfig
Code:

fwe0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=8<VLAN_MTU>
ether 02:e0:18:0e:94:4b
inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
ch 1 dma 0
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
lladdr 0.e0.18.0.0.e.94.4b.a.2.ff.fe.0.0.0.0
bfe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 00:e0:18:e2:38:18
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
plip0: flags=108810<POINTTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MUTLICAST>metric 0 mtu 16384
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
inet6 ::1 prefixlen 128
inet 127.0.0.1 netmask 0xff000000

dmesg
Code:

ums0: 3 buttons and Z dir.
Timecounter "TSC" frequency 2004558132 Hz quality 800
Timecounters tick every 1.000 msec
firewire0: 1nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
and the rest is GEOM_LABEL s


Fin7PL 06-08-2009 04:06 AM

fwe0 is your wireless ethernet over firewire? you use that or the card. (rj45)

Code:

bfe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 00:e0:18:e2:38:18
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active

So this bfe0 is your ethernet card. and it is plugged in too.

It seems it doesn´t get any ip, you have static ip or do you normally get it automatically.

try command
Code:

dhclient bfe0
It should try to get some ip bound to your bfe card.

and post the output. thanks.

To get the dhcp work at boottime place this line to your /etc/rc.conf

Code:

ifconfig_bfe0="DHCP"

jus71n742 06-08-2009 11:19 PM

Kazahh it works....thank you very much.


All times are GMT -5. The time now is 02:46 PM.