LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 07-20-2005, 04:08 PM   #1
24jedi
Member
 
Registered: Jul 2003
Location: Richmond, VA
Distribution: FreeBSD 5.4
Posts: 75

Rep: Reputation: 15
Apache2 + PHP5.0.3


Hello and TIA

I have Apache 2.0, php 5.0.3 and mysql_4.1.11 installed on a FreeBSD 5.4-release box. All three appear to be working as I can manaully create a database, and view phpinfo() from a remote workstation to the bsd box.

My issuse is I am trying to install a CMS package called etomite . After uploading the appropriat files, I try to install from the browser but get the following error:

Fatal error: Call to undefined function session_start() in /usr/home/donmunyak/public_html/etomite/index.php on line 30

After looking at the phpinfo() again, I noticed that the section that displays seesion information is mising as well as mysql support.

After doing some searching I found on the php site that, I found that mysql for php5 is not enabled by default It should have been compile with the --with-mysql[=DIR] configure option, as well as the mysql library apparently was not bundled.

At this point "I think" I have to recompile PHP, except from what I remember, I used the pkg_add to install php5.

How do I recompile php5 for mysql support ?

Do I also need to do anything to apache or mysql ?

Thanks

Last edited by 24jedi; 07-20-2005 at 04:18 PM.
 
Old 07-21-2005, 04:07 PM   #2
24jedi
Member
 
Registered: Jul 2003
Location: Richmond, VA
Distribution: FreeBSD 5.4
Posts: 75

Original Poster
Rep: Reputation: 15
followup

Success

I did not have to recompile anything. The problem was I had not installed the php5-extensions.

I drilled down to /usr/ports/lang/php5-extensions
typed make & make install

This initially failed because of some dependencies (ghostscript-gnu), so I went to the ports collection for ghostscript-gnu and installed them.

Then went back to php5-extensions...make & make install.

After finishing the install I rebooted the box for good measure.

phpinfo() now lists everything I was missing and my install of etomite went successful.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SLES9/apache2 and PHP5 scabrous1 Suse/Novell 1 12-15-2005 06:14 AM
Apache2 and PHP5 SpiderIRE Linux - Software 3 09-30-2005 04:25 PM
Apache2 and PHP5 rul3r Slackware 7 09-11-2005 06:21 PM
Installing Apache2 and PHP5 biglaz Linux - General 1 10-15-2004 11:42 PM
Apache2 with PHP5 on Fedora C2 cdrobsonjr Linux - Software 5 09-13-2004 06:06 PM


All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration