LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Apache not autostarting (http://www.linuxquestions.org/questions/%2Absd-17/apache-not-autostarting-263305/)

Atrocity 12-06-2004 01:45 PM

Apache not autostarting
 
I just installed freebsd 5.3 and I installed apache, everything is working fine except that apaches isnt starting on boot, it has to be manually started after login.

Is there a way to correct this through apaches config files?
Or is there some statement I can put in maybe the rc.conf file to load apache at start??

chort 12-06-2004 02:41 PM

Did you compile Apache from source, or are you using the built-in version that comes with FreeBSD?

If you're using the built-in version, check the relevant section of the handbook.

Atrocity 12-07-2004 12:38 PM

I compiled it from /usr/ports directory

chort 12-07-2004 12:51 PM

OK, read the handbook then. I remember in 4.x when I did it that way there was an init script in /usr/local/etc/somethingorother. I don't know if 5.x has changed that.

sigsegv 12-07-2004 12:53 PM

probably you need to add apache_enable="YES" to your rc.conf. They changed all the local rc scripts to look to make sure they're enabled in rc.conf before they'll start up now.

But yes, read the handbook (which would have told you this) :p

Atrocity 12-07-2004 12:53 PM

All set, thanks alot

Read that link you gave me and it gave me what to put in my rc.conf

apache_enable="YES"

Atrocity 12-07-2004 12:54 PM

haha we posted at the same time, thank you to you as well sig for the info

ub3rj3phf 12-08-2004 01:36 PM

Code:

apache_enable="YES"
Will that work with apache+mod_ssl installed from ports?

Atrocity 12-08-2004 01:58 PM

That should work on that, I dont see why not, since it doesnt specify even the version type 1 or 2, I dont see why it would matter if it was ssl. I think it would work fine


All times are GMT -5. The time now is 07:33 PM.