LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 02-13-2003, 12:17 AM   #1
tied2
Member
 
Registered: Jun 2002
Location: Florida
Distribution: Redhat, FreeBSD, FC 6
Posts: 220

Rep: Reputation: 30
adding user to wheel group


HI, I installed freebsd 5.0 and I made a mistake at install, well ok I made a lot of mistakes but have sorted thru most of them. One thing I'm having trouble with is how to add my user account to the wheel group so i can become su. I tried /stand/sysinstall but couldn't see a option to edit user accounts only create new ones. Can someone help me out here?

Thanks!

Last edited by tied2; 02-13-2003 at 12:29 AM.
 
Old 02-13-2003, 01:17 AM   #2
ferreter
Member
 
Registered: Oct 2002
Location: USA, IL
Distribution: Debian/Gentoo/Slack
Posts: 215

Rep: Reputation: 30
The easiest way in my experience is to simply open /etc/group with vi, nano, or emacs and just add the user to the wheel group like so:

wheel::10:root,username

toodles!
 
Old 02-13-2003, 01:35 AM   #3
tied2
Member
 
Registered: Jun 2002
Location: Florida
Distribution: Redhat, FreeBSD, FC 6
Posts: 220

Original Poster
Rep: Reputation: 30
thanks ! I tryed that but I had done:

wheel:*:1:root:username
a misstake!
thanks again!
 
Old 02-13-2003, 01:49 AM   #4
ferreter
Member
 
Registered: Oct 2002
Location: USA, IL
Distribution: Debian/Gentoo/Slack
Posts: 215

Rep: Reputation: 30
Not a problem, i think I may have made that mistake in the past once as well..hehe..
 
Old 03-12-2003, 12:20 PM   #5
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 825

Rep: Reputation: 30
or when you add a new user if to be added to any groups besides theirs, you put wheel
 
Old 09-22-2007, 07:55 PM   #6
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
Quote:
Originally Posted by ferreter View Post
The easiest way in my experience is to simply open /etc/group with vi, nano, or emacs and just add the user to the wheel group like so:

wheel::10:root,username

toodles!
I added this line to /etc/group and that didn't do it. Perhaps there's some other way? Or do i need to remove the other line for my users name?

I am using the dreaded gnome (about to get rid of it) on debian.
 
Old 09-23-2007, 02:28 AM   #7
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
You need to logout and then log back in.
 
Old 09-24-2007, 02:14 AM   #8
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
I logged out of the session after adding that line, and still doesn't work.

I noticed that there is a , instead of a : there on the original post. Is this so or is it a typo?

Last edited by trebek; 09-24-2007 at 02:23 AM.
 
Old 09-24-2007, 08:52 AM   #9
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
It needs to look like:
Code:
wheel:*:0:root,user_here
 
Old 09-26-2007, 05:16 AM   #10
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
Hey, i'm back.

I reinstalled kubuntu and upgraded from dapper to edgy. Amazingly, in edgy, sudo works fine. I not only able to type sudo, but it asks me for the password again, before executing the command, and of course, it asks me again if i close the shell or if i've been idle for a while.

Don't know what's the difference here. I'll have a look at the sudoers and group files in /etc/ to see what i can find.

Thanks a lot guys, i ended up knowing much more than i used to be, so thanks again, you guys rule!
 
Old 09-28-2007, 04:22 AM   #11
saivinob
LQ Newbie
 
Registered: Aug 2007
Location: Bangalore, India
Distribution: Debian Etch, CentOS 5, FreeBSD 6.2
Posts: 11

Rep: Reputation: 0
anomie+phil.d.g works

Hi,
the discussion was about getting su ability in FreeBSD but turned to Kubuntu?
Anyway even I wanted this facility so added my name to wheel line in /etc/group as root and then logged out and logged back as normal user(the user name I added to wheel line). Now I can use the su facility.
Thanks anomie and phil.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
adding user to group ryancoolest Linux - Newbie 9 04-14-2008 12:50 PM
Adding new group to existing user ALF Linux - Software 7 05-08-2006 09:35 PM
after adding user to group peter72 Linux - General 2 08-01-2005 10:17 AM
NO SOUND IN XMMS EVEN AFTER ADDING USER TO /etc/group roorings Linux - Software 0 10-25-2003 02:46 PM
adding user to a group Chilipepa Linux - Newbie 2 09-27-2003 11:08 AM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration