LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 09-22-2005, 05:02 PM   #1
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
1024x768 Console!! (higher available!)


I finally got a 1024x768 console in freeBSD... which is the native resolution on my notebook... normally you have the little 640x480 square in the middle... no longer!!

I'm going to write a detailed HOWTO for LinuxAnswers tomorrow.. and I'll be sure and post it back here... I struggled for months trying to figure out what I was doing wrong.. now that I know how to do it.. it's very very easy..

I did it on FreeBSD 6.0 Beta5... but I'm going to try it on my standard 5.4 installation tomorrow morning to make sure it works equally as well...

Hopefully this will help others along the way..

Last edited by halo14; 09-22-2005 at 05:03 PM.
 
Old 09-22-2005, 05:29 PM   #2
JamieBrown
Member
 
Registered: Jan 2005
Location: Great Ayton, North Yorkshire, UK
Distribution: Gentoo, Mandriva, RHES, Debian
Posts: 61

Rep: Reputation: 15
Hi Halo!

Please do! I'd be interested in hearing more about it. Is it just a BSD thing?

Jamie.
 
Old 09-22-2005, 06:08 PM   #3
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Original Poster
Rep: Reputation: 45
well the BSDs generally are limited to 640x480 console resolution by default, yes. Pretty much all Linux distro's support at least 1024x768 consoles with a kernel parameter in the boot manager such as "vga=791" for 1024x768x16bit color...

I had heard that you can get the decent console res. on BSD but had never been able to get ti to work right...

I will surely get it done tomorrow though, so we can all enjoy!
 
Old 09-23-2005, 07:41 AM   #4
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
Sounds good! I'm interested in see this also. This is one of my frustrations with FreeBSD. My computer is capable of 132x60 text console but I've never been able to get more than 100x32.

Kent
 
Old 09-23-2005, 09:27 AM   #5
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Original Poster
Rep: Reputation: 45
posting this here until I get the time to appropriately format it!!! The I will submit to LinuxAnswers

note: this is a rough draft, and will have better formatting in the future, however, the information is correct and should work accordingly.

This document is an instruction on how to provide your FreeBSD installation with a high resolution console.

I have successfully done this in FreeBSD 6.0-BETA5 and FreeBSD 5.4-RELEASE.

In the 6.x series, there is support for consoles up to 1600x1200x32 resolution. 5.x supports a max of 1024x768.. which is fine for most people.

First thing we have to do is add VESA and SC_PIXEL_MODE to the kernel and rebuild. You should always cvsup and rebuild your kernel and world to the latest available. However, don't try to 'optimize' the BSD kernel. It is already well optimized. If there is an option, like this, that you need to have, then go for it. We need to open the kernel config file. I would recommend that you cvsup first so that you rebuild the latest world/kernel, but it's optional.
Code:
cvsup -h cvsup2.freebsd.org -g -L 2 /usr/share/examples/cvsup/standard-supfile
Obviously, you can use whichever cvsup server you want. You can install fastest_cvsup to fins what server is fastest for your location as well. If this is the first time you are cvsup-ing, it will take some time. When it completes, we will continue.
Code:
cp /usr/src/sys/i386/conf/GENERIC /usr/src/sys/i386/conf/GENERICVESA
Name it to whatever you want.
Code:
vi /usr/src/sys/i386/conf/GENERICVESA
You will see, a couple of lines down an "ident GENERIC" line. You can change this if you want. It will be the display of the kernel in uname.

Directly after that, you will start to see 'option xxxxx #Description' sections..

This is where we add our options:
Code:
options   VESA
options   SC_PIXEL_MODE
Save your changes and exit.

From here, you generally build the world, and the kernel, install the kernel, reboot to single-user mode, mergemaster, installworld, etc... but I'm going to skip the buildworld because it will eat up a lot of time, and we can do it after the kernel.

Code:
cd /usr/src
make buildkernel KERNCONF=GENERICVESA
make installkernel KERNCONF=GENERICVESA
reboot
Now, you won't get the resolution just yet, we're not quite done. Boot back up and do the following:

Code:
kldload vesa
vidcontrol -i mode | less
You should see a punch of different modes. Scroll through and find one you'd like. For me, 1024x768x24 is the size I want. The first column shows the mode number, mine being 280.

Choose the one you want and try:
Code:
vidcontrol MODE_xxx
Substituting "xxx" for the number of the mode you want. The screen will go bank for a second, then it should come back with the prompt. If it cannot handle the resolution you specified, it should return with an error.

If it works, GREAT! Now we can add this to /etc/rc.conf to load on boot-up. However, we must make sure we load vesa on boot-up as well.
Code:
vi /boot/defaults/loader.conf
see the line that says:
Code:
vesa_load="NO"
change it to "YES" (maintaining caps)
Save, and exit.
Code:
vi /etc/rc.conf
and add to the end:
Code:
allscreens_flags="MODE_xxx"
again, substituting "xxx" for the mode of your choice.

Reboot, and it should come up to the correct console resolution. It does take a while for it to load since it's from a config file. Not like the kernel parameter in Linux where the whole thing boots full-screen. In my case, it goes to full screen just before loading the Linux ABI.
 
Old 09-23-2005, 07:53 PM   #6
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
It works!

You don't need to load the vesa module since you built it into the kernel. All you need after that is the allscreens addition to rc.conf.

I've tried to get this to work for a long time but never found the "MODE_xxx" part.

Thanks!

Kent
 
Old 10-02-2005, 12:51 PM   #7
taylor_venable
Member
 
Registered: Jun 2005
Location: Indiana, USA
Distribution: OpenBSD, Ubuntu
Posts: 892

Rep: Reputation: 40
Hey, pretty sweet! As per your instructions, it all works fine. (Although, it is true that you don't need to load the vesa module.) The only problem is that the green screensaver doesn't work now. When the time comes, the display simply stops updating, rather than going off. Probably a hardware thing. But great job figuring that out, I've been looking for it for a while!
 
Old 10-02-2005, 07:38 PM   #8
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
I am clueless.

When I do a vidcontrol MODE_280 all I get is the usage message from vidcontrol. Indeed, any MODE_XXX does that. What am I missing?

Cheers--
Charles
 
Old 10-03-2005, 07:29 AM   #9
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Original Poster
Rep: Reputation: 45
cnjohnson, try this:
Code:
vidcontrol -g 100x37 VESA_800x600
tell me if that works better. 6.x has an enhanced framebuffer, I forgot to update it with the correct function for 5.x.
 
Old 10-03-2005, 07:12 PM   #10
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
Better!

Thanks.

Cheers--
Charles
 
Old 10-08-2006, 06:14 PM   #11
zulsolar
LQ Newbie
 
Registered: Mar 2005
Location: Buenos Aires, Argentina
Distribution: Slackware, Solaris 10, Ubuntu
Posts: 9

Rep: Reputation: 0
Thumbs up

It works!!! Thank you!!!
 
Old 04-06-2007, 09:08 PM   #12
rehab junkie
Member
 
Registered: Nov 2003
Location: /var/local/pub/bar
Distribution: OSX 10.4.9
Posts: 259

Rep: Reputation: 30
Quote:
Originally Posted by halo14
[b]If it works, GREAT! Now we can add this to /etc/rc.conf to load on boot-up. However, we must make sure we load vesa on boot-up as well.
Code:
vi /boot/defaults/loader.conf
see the line that says:
Code:
vesa_load="NO"
change it to "YES" (maintaining caps)
Save, and exit.
Sorry to drag up the past, but seeing as no one else mentioned it, I need to add: Argh! No! Don't EVER modify /boot/defaults/loader.conf! Add the line to /boot/loader.conf instead, it is an override.
 
Old 08-25-2008, 01:47 PM   #13
rob0t
Member
 
Registered: Jun 2003
Location: Chicago
Distribution: Arch, CentOS, Ubuntu, FreeBSD, Solaris / OpenIndiana
Posts: 95

Rep: Reputation: 16
THHHHHAAANNNKKK YOUU!!!

This has solved my problem and it's a very thorough howto!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get Resolution higher than 1024x768 with NVIDIA driver AntWarrior Ubuntu 3 03-17-2007 09:30 PM
So why can't I get Debian (2.6.x kernel) to go any higher than 1024x768 res.? dhatcher Debian 15 07-22-2005 12:27 PM
Intel Extreme Graphics 2 and higher resolutions than 1024x768? alzen Linux - Hardware 1 11-06-2004 02:33 AM
I can't set the resolution higher than 1024x768 Prism Slackware 5 08-27-2004 12:45 PM
Basic gfx card for RedHat 8.0 at 1024x768@ 70Hz or higher fishsponge Linux - Hardware 1 08-20-2004 09:36 AM


All times are GMT -5. The time now is 08:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration