LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   OpenBSD 7.4 is released. (https://www.linuxquestions.org/questions/%2Absd-17/openbsd-7-4-is-released-4175729945/)

YesItsMe 10-16-2023 08:32 AM

OpenBSD 7.4 is released.
 
Finally!
https://www.openbsd.org/74.html

Upgrading from 7.3:
https://www.openbsd.org/faq/upgrade74.html

Enjoy!

hitest 10-16-2023 09:30 AM

Wow! Thanks for the heads-up! Upgrading today. :)

YesItsMe 10-16-2023 09:47 AM

Already upgraded here. It all went fine, as (almost) always. This time, no additional steps were required (not even deleting any old configuration files).

Code:

# sysupgrade
(reboot did sysmerge without any problem)
# pkg_add -u

You should still view the post-installation log (you'll get it in your mailbox) and/or watch the reboot. Just in case something (fw_update? sysmerge?) went wrong.

rufwoof 10-16-2023 11:26 AM

I did a new install on my desktop system where OpenBSD boots on the second HDD (SDD first drive used as a grub4dos boot of Linux). Took all of a 5 minutes or so to install, setup user ...etc. Then

pkg_add chromium x11vnc
.. another few minutes

Configured it for user to use cwm
echo cwm >/home/user/.xsession

Logged in as user and
Xephyr :1 -dpi 141 -screen 1366x768 &
DISPLAY=:1 cwm &
DISPLAY=:1 x11vnc -forever &

and from my laptop connect to that
vncviewer 192.168.1.1 # servers IP address
and use F8 menu option to switch to toggle to fullscreen (I have tigervnc installed on that), so that the keys work as intended i.e. ctrl-? (ctrl shift /) and enter/run chrome

The above dpi value of 141 just best fits with my preferred size, as is the 1366x768 my laptops screen size (desktop/server runs at 1920x1080).

So my laptop, running Linux (Fatdog) can vnc into the desktop OpenBSD and browse/whatever as just another 'window'. My desktop is hard wired (ethernet) whilst my laptop is wifi, so I can lounge around with the laptop as a form of remote control (of the OpenBSD box). You can also forward sound using sndiod, but I have a long extension lead from the desktop headphone output that easily stretches to the couch :) Playing youtube videos are OK, not great, good enough.

If chrome menu fonts are too large/small I find that using the ...
chrome --force-device-scale-factor=1.6
... does the job for me, my setup however and I don't need to do that.

hitest 10-16-2023 11:40 AM

Upgrade completed.

Code:

OpenBSD puffy.darkstar.home 7.4 GENERIC.MP#1397 amd64

fatmac 10-16-2023 12:04 PM

Thanks for the 'heads up', will go get my copy now. :)

jmccue 10-16-2023 02:43 PM

Quote:

Originally Posted by YesItsMe (Post 6459120)
Already upgraded here. It all went fine, as (almost) always. This time, no additional steps were required (not even deleting any old configuration files).

You may also want to do this to remove old cruft:

Code:

pkg_delete -a
see the manual for more info

YesItsMe 10-16-2023 03:32 PM

True, thank you.

hitest 10-16-2023 03:48 PM

Just a heads-up about changes to OpenBSD 7.4. Shutdown and reboots now require membership in the new _shutdown group. Edit /etc/group to make that change.

https://undeadly.org/cgi?action=arti...20230620064255

rufwoof 10-16-2023 05:00 PM

Quote:

Originally Posted by rufwoof (Post 6459142)
I did a new install on my desktop system where OpenBSD boots on the second HDD (SDD first drive used as a grub4dos boot of Linux). Took all of a 5 minutes or so to install, setup user ...etc. Then

pkg_add chromium x11vnc
.. another few minutes

Configured it for user to use cwm
echo cwm >/home/user/.xsession

Logged in as user and
Xephyr :1 -dpi 141 -screen 1366x768 &
DISPLAY=:1 cwm &
DISPLAY=:1 x11vnc -forever &

and from my laptop connect to that
vncviewer 192.168.1.1 # servers IP address
and use F8 menu option to switch to toggle to fullscreen (I have tigervnc installed on that), so that the keys work as intended i.e. ctrl-? (ctrl shift /) and enter/run chrome

The above dpi value of 141 just best fits with my preferred size, as is the 1366x768 my laptops screen size (desktop/server runs at 1920x1080).

So my laptop, running Linux (Fatdog) can vnc into the desktop OpenBSD and browse/whatever as just another 'window'. My desktop is hard wired (ethernet) whilst my laptop is wifi, so I can lounge around with the laptop as a form of remote control (of the OpenBSD box). You can also forward sound using sndiod, but I have a long extension lead from the desktop headphone output that easily stretches to the couch :) Playing youtube videos are OK, not great, good enough.

If chrome menu fonts are too large/small I find that using the ...
chrome --force-device-scale-factor=1.6
... does the job for me, my setup however and I don't need to do that.

For sound from the server (desktop system where x11vnc is running) to be played on your laptop, sndiod can be used. Chrome however doesn't seem to support that, so you have to resort to firefox instead
pkg_add firefox-esr

Then in OpenBSD as root
rcctl set sndiod flags -L-
then you can pipe sound to the remote system
AUDIODEVICE=snd@<ip of laptop>/0 firefox-esr
for me for instance
AUDIODEVICE=snd@192.168.1.5/0 firefox-esr
as my laptop IP is assigned that IP (ifconfig)
As that's running a Linux system (Fatdog) I have to download and compile sndiod, but that was a simple .configure;make;make install process that only takes a few minutes. And it also has to be set to listen for that sound stream. You have to create a user for that snd daemon (useradd ....)
useradd -r -g audio -s /sbin/nologin -d /var/run/sndiod sndiod
and then to have it listen
sndiod -dddd -a on -f rsnd/1 -L-
You may have to play around with what sound card to use, mines card 1 but it may be card 0 (rsnd/0 -L-)

So with the earlier vnc setup you have a screen that can be matched to your actual laptop devices screen size, and where both the screen and sound appear on the laptop, and where you can disconnect from a session and reconnect again later.

From there, install some security around that, have vnc for instance require a password, or pipe the vnc through a ssh tunnel, or via a virtual private network. n2n is good for that. So you might have your desktop serving vnc out through your home hubs firewall and from a remote location connect into the same vpn network again outbound through a firewall, and have your OpenBSD session and sound available remotely without having to open up any firewall ports. https://github.com/ntop/n2n

I pkg_add mtpaint to grab a screen shot using
sleep 5;mtpaint -s ... in a terminal window and then minimised that out of the way (alt return in cwm) that shows the firefox picture in picture look https://i.postimg.cc/4yknQw5c/snapshot.png

Mostly its played/sounded OK for the half hour or so that youtube has been playing (searched and 'watch here' using duckduckgo to avoid the ads) but has jittered/stuttered a couple of times during that half hour.

rufwoof 10-17-2023 05:02 AM

A workaround for otherwise not having Chrome's sound being forwarded, not a ideal solution but OK, for vnc + sound forwarding ...

On the host (server)

rcctl set sndiod flags -s default -m play,mon -s mon
rcctl restart sndiod

i.e. as per the online manual to record from all sound sources

Then

aucat -f snd/mon -o - | AUDIODEVICE=snd@192.168.1.5/0 aucat -i- -

to have aucat capture that recording stream and forward it to the laptop

On the laptop/remote the same

sndiod -d -a on -f rsnd/1 -L-

to set it to listen/output that sound.

The IP and card numbers may vary according to your hardware setup

Along with vnc'ing in as I outlined in earlier posts and local usage wise you see/hear videos/played-youtubes on both the server and laptop, but where the laptop image and sound lag the servers, and where the laptops video/sound does drift a little, so out of lip-sync for instance. But usable. The lag of video and sound are much the same on my setup, so the lip sync isn't annoyingly bad, rather just a noticeable difference when its a someone talking to the camera scene/video.

YesItsMe 10-26-2023 05:27 AM

It begins!

Syspatch 001 (all architectures):
Fix several input validation errors in the X server. CVE-2023-5367 CVE-2023-5380 CVE-2023-5574

Syspatch 002 (all architectures):
A network buffer that had to be split at certain length could crash the kernel.

hitest 11-05-2023 03:16 PM

I had some crashing issues with Firefox running out of memory so I added my regular user to the staff class and changed some memory settings in /etc/login.conf
Many thanks to jggimi for the kind assistance in this area. That did the trick. :)

YesItsMe 11-06-2023 05:48 AM

Which settings did you... well, set? Sounds like it could be useful for other LQ members too.

hitest 11-06-2023 09:37 AM

Quote:

Originally Posted by YesItsMe (Post 6463154)
Which settings did you... well, set? Sounds like it could be useful for other LQ members too.

Good morning! I found this website helpful.

https://www.czettner.com/2022/05/15/...rst-steps.html

Here's a snippet of my /etc/group.

Code:

wheel:*:0:root,hitest
daemon:*:1:daemon
kmem:*:2:root
sys:*:3:root
tty:*:4:root
operator:*:5:root,hitest
bin:*:7:
wsrc:*:9:
users:*:10:
auth:*:11:
games:*:13:
staff:*:20:root,hitest
wobj:*:21:
sshd:*:27:
_portmap:*:28:
_identd:*:29:
_rstatd:*:30:
guest:*:31:root
_rusersd:*:32:
_fingerd:*:33:
_sshagnt:*:34:
_x11:*:35:
utmp:*:45:
_unwind:*:48:
_traceroute:*:50:
_ping:*:51:
_unbound:*:53:
_dpb:*:54:
_pbuild:*:55:
_pfetch:*:56:
_pkgfetch:*:57:
_pkguntar:*:58:
_spamd:*:62:
_radius:*:63:
_token:*:64:
_shadow:*:65:
crontab:*:66:
www:*:67:
_isakmpd:*:68:
network:*:69:
_rpki-client:*:70:
_bgplgd:*:71:
authpf:*:72:
_syslogd:*:73:
_pflogd:*:74:
_bgpd:*:75:
_tcpdump:*:76:
_dhcp:*:77:
_mopd:*:78:
_tftpd:*:79:
_rbootd:*:80:
_ppp:*:82:
_ntp:*:83:
_ftp:*:84:
_ospfd:*:85:
_hostapd:*:86:
_dvmrpd:*:87:
_ripd:*:88:
_relayd:*:89:
_ospf6d:*:90:
_snmpd:*:91:
_agentx:*:92:
_ypldap:*:93:
_rad:*:94:
_smtpd:*:95:
_rwalld:*:96:
_nsd:*:97:
_ldpd:*:98:
_sndio:*:99:
_ldapd:*:100:
_iked:*:101:
_iscsid:*:102:
_smtpq:*:103:
_file:*:104:
_radiusd:*:105:
_eigrpd:*:106:
_vmd:*:107:
_tftp_proxy:*:108:
_ftp_proxy:*:109:
_sndiop:*:110:
_syspatch:*:112:
_slaacd:*:115:
dialer:*:117:
_shutdown:*:118:hitest

Here's a snippet of my /etc/login.conf. I increased the amount of RAM used. Adjust your settings dependent on how much RAM you have.

Code:

# Staff have fewer restrictions and can login even when nologins are set.
#
staff:\
        :datasize-cur=30200M:\
        :datasize-max=infinity:\
        :maxproc-max=512:\
        :maxproc-cur=256:\
        :ignorenologin:\
        :requirehome@:\
        :tc=default:



All times are GMT -5. The time now is 10:18 AM.