LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   FreeBSD+Xorg-7.05 = mouse + keyboard issues (https://www.linuxquestions.org/questions/%2Absd-17/freebsd-xorg-7-05-%3D-mouse-keyboard-issues-894871/)

igadoter 08-01-2011 05:20 AM

FreeBSD+Xorg-7.05 = mouse + keyboard issues
 
Hi,
I've just installed FreeBSD 8.1 - seems it's OK except the Xorg server is unable to detect a mouse and a keyboard. I tired several options in the xorg.conf file but none work. This version of Xorg server relies on HAL to detect devices. Know I am thinking about two possible solutions: to downgrade the X server or to install HAL. But maybe there is a simple solution of my problems.

Any help are very welcomed.

vermaden 08-01-2011 05:41 AM

Add this to /etc/X11/xorg.conf file

Code:

Section "ServerFlags"
  Option "DontZap"        "off"
  Option "AutoAddDevices"  "off"
EndSection

... and You should install 8.2-RELEASE at least to be up-to-date, no point in using older releases.

igadoter 08-01-2011 07:31 AM

The problem was the "DontZap" option. Now everything is OK.

I spent hours installing FreeBSD 8.1 - is there a painless way to upgrade to 8.2 ?

vermaden 08-01-2011 07:40 AM

Acutally yes, there is, this is the schema for that upgrade:

Code:

# freebsd-update upgrade -r 8.2-RELEASE
# freebsd-update install
# shutdown -r now
# freebsd-update install
# shutdown -r now

... and thats it, You will also have to read (and understand) on screen information and answer the questions to have merged configuration files.

igadoter 08-01-2011 08:06 AM

Happily it is the new installation - there are no custom settings. What about the packages - I've got a bunch of them already installed. But I am aware most about USB wifi cards - this is the only way for the permanent internet connection - via wireless router. I have a look at HCL for USB wifi cards - it seems for me it may be difficult to get one of these cards.

vermaden 08-01-2011 08:15 AM

For packages, it would be something like that (after upgrade):

Code:

# pkg_info -qoa > PACKAGES
# pkg_delete -a
# rm -rf /usr/local /var/db/pkg
# sh
# while read I; do pkg_add -r $( basename ${I} ); done < PACKAGES

You may also try pkg_upgrade command from bsdadminscripts package or portmaster -PP (with that option it will only use packages without needless compilation).


All times are GMT -5. The time now is 09:06 AM.