LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 06-23-2015, 02:41 AM   #1
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
FreeBSD manual update including all ports


This post is a refresher how-to for myself that I hope will also be helpful to others. It is incomplete, covering only what I found necessary, and also includes what may be obvious to others, so I ask those who actually know what they are doing to please indulge me...

Although I have been running my FreeBSD system for a little over a year, I still have not developed the intuitive sense of how to manage system and ports updates the way I do with my Slackware machines.

I have been intensively occupied with Slackware based projects since the first of the year and have allowed my FreeBSD machine to run mostly unattended during that time (it does not face the internet). So I decided to bring it all up to date the last few days. That at first became somewhat confusing, even with my installation notes, but in the end has been a very rewarding exercise - so I thought I would summarize my re-learning experience here to serve as my long term memory, and hopefully for the benefit of anyone else learning their way around FreeBSD.

System and Kernel Updates

I never remember exactly how to do this, but it is so simple I can always get it done from the FreeBSD Handbook and my own notes:

Code:
freebsd-update fetch
freebsd-update install

To see current kernel and system patch level...

uname -a
freebsd-version
That part is easy, I have updated from FreeBSD-10.0 to 10.1 (with suitable options), and a few patch levels since without problems. High confidence in these.

Ports Updates

I love the ports system almost as much as SlackBuilds! But I find that I am never quite sure of the status of my ports and each time I install or update I seem to have to re-learn the tools, except for the make options.

This time I also seemed to have a few loose ends from previous updates, probably because I have never updated all my ports and probably did not follow the /usr/ports/UPDATING notes carefully in the past...

So I decided to resolve all issues and update all ports that had updates - all 318 out of 503.

My first stumbling block was that I never seem to remember how to query the system for ports and package information quickly. I have pkg and portmaster installed, so I worked my way through both man pages, again, and looked at the Handbook. Here are the essentials for quick info (there are other ways - these got me through the day!):

Code:
List all packages, including ports, with available new versions...
pkg version -l "<"

List all installed ports, and note available new versions...
portmaster -L

Check currently installed version of any package...
pkg info |grep package-name
OK, now I need to update my ports tree, again easy...

Code:
portsnap fetch
portsnap update

OR simply...

portsnap fetch update
Here I was a bit confused and had to learn, or re-learn how to use portmaster. I never like to unleash large update processes, without knowing what would be the outcome with some certainty - and I had no certainty about portmaster updates!

So, more time with the man page and some experimentation led me to the following path to enlightenment - now clearly enshrined in my notes:

Code:
To list all ports in need of updates, in dependency order...
portmaster -an {-x problem-package}

If the list processing stops due to error that you cannot immediately resolve,
add one or more -x terms to ignore those packages for now.

To update a ports package and its dependencies, create a package and remove
old source archives...

portmaster -gd package-name

Note that package name can be partial and will update all matching ports!
Test with -n first to be sure you update only what you need!

You can update all installed ports at once, if it succeeds, but I never do...
portmaster -a

You can update all packages that depend on a given package too...
portmaster -gd -w -r package-name
Using the above on individual packages and smaller groups I was able to reliably work my way through all my ports updates through the course of the afternoon.

I had a few problem ports that needed special attention. texlive-base, tex-kpathsea and gnomehier come to mind. Each of these was the result of previously unresolved /usr/ports/UPDATING steps, as far as I could tell.

gnomehier has been removed from ports but was installed and could not be removed due to multiple dependencies. I ignored it with -x option until others were updated and it could then be removed as dependencies had been resolved by other updates.

texlive-base and tex-kpathsea had a circular dependency problem that would not resolve. So I finally...

Code:
cd /usr/ports/print/texlive-base
make deinstall
make reinstall
make package
tex-kpathsea was resolved by that process.

I then ran a check on the ports db and removed a few loose ends - ports not installed but in the db:

Code:
portmaster --check-port-dbdir
I now have a fully updated system again, including all ports!

And equally as important, I now have a short list of methods for doing it next time, and the confidence that comes from knowing my way around a little better.

I hope this is reassuring, if not helpful to someone else learning their way around FreeBSD.
 
Old 06-24-2015, 01:48 PM   #2
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Debian, Slackware
Posts: 7,342

Rep: Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746
Good stuff, man! A very valuable post for FreeBSD users learning the ropes with ports. I maintain a FreeBSD 10.1 VM, and I love this OpenBSD 5.7 box.
 
1 members found this post helpful.
Old 06-29-2015, 08:01 AM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,727

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
The handbook also covers upgrading in detail: https://www.freebsd.org/doc/handbook...bsdupdate.html
 
1 members found this post helpful.
Old 06-29-2015, 02:36 PM   #4
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263

Original Poster
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Yes, the FreeBSD Handbook covers everything to a level of excellence that should be a model for all others!

While I can and do always find the necessary answers in the Handbook and man pages, I have not reached the intuitive point where I already know (i.e. remember) what tool to use for each part of the job.

For example, when managing a Slackware box I know how to discover package status, how to install, remove, upgrade and verify packages, and rebuild them if necessary. I may still need to peek at the man pages, but I pretty much know what to use and where to look.

But with FreeBSD I still don't remember the relationships between freebsd-update, ports, portmaster, pkg, the pkg db, et al. I often don't know how to quickly discover what is there and which tool to use for a given package management task, so I have to re-learn from the Handbook and work my way through it each time. (The exception to this has been the ports make targets which seemed to stick with me from the start.)

To be clear - this is not a fault of FreeBSD! But for whatever reason, I seem to be struggling with finding the intuitive feel for these "contact points" with FreeBSD more than usual... maybe I am just getting old-er and taking more effort to learn those new tricks!

By writing the above post, and a fresh cheat-sheet for myself, I wanted to capture the overview that was clear to me at that time, after working through a complete update of the machine in one extended session. It seems to have done the trick for now!
 
Old 06-30-2015, 06:46 AM   #5
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,727

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
Quote:
Originally Posted by astrogeek View Post
But with FreeBSD I still don't remember the relationships between freebsd-update, ports, portmaster, pkg, the pkg db, et al.
Part of the problem is that you're equating *BSD to Linux. *BSD is a different animal. The only similarities are (in a nutshell):

1) UNIX-like system
2) Some of the same software available for both
3) Free and open source

In the Linux world complex dependency resolving package managers are the priority for most end users, in the BSD world not so much. In the Linux world, fine grained control over package management foo is a must, in the BSD world, it's not.

The BSDs are descended from the original AT&T UNIX. Each *BSD is some shape or form a fork of the Berkeley Software Distribution, derived from 386BSD. Each *BSD is a "complete operating system" in it's own right, developed by a team of developers working for the same project. It is not a "distribution" of thousands of packages all fitted together to make an operating system.

The BSDs have a base system and a ports tree. The base system is considered to be the OS. The ports tree is 3rd party software and thus - not part of the OS. The base system does not consist of 'packages' of any kind.

Ports and packages are, as a general rule, the same thing. When you build from ports a package or packages is the end result. The result is 3rd party software which is usually installed under /usr/local (not part of the base system).
Quote:
Originally Posted by astrogeek View Post
I often don't know how to quickly discover what is there and which tool to use for a given package management task, so I have to re-learn from the Handbook and work my way through it each time. (The exception to this has been the ports make targets which seemed to stick with me from the start.)
freebsd-update is used by FreeBSD to upgrade the base system only, for typical security patches etc and for major/minor release upgrades. If you have source code installed, it will also update that (can take ages).

portsnap, portmaster, portupgrade, etc all relate to the ports tree and are only for ports management. The first just fetches a snapshot of the ports tree and keeps it updated. The others two used for searching for updates, ports and managing build queues/automating port builds, etc.

pkg (the successor to the old pkg_add, pkg_delete, pkg_info tools) is used for installing/removing/upgrading binary packages.

It's common for many new *BSD users to jump straight in and assume that they need to build everything from source, whereas in fact pre-built packages are fine 99% of the time (hint: that's kind of why there are binary packages).
 
2 members found this post helpful.
Old 08-26-2015, 10:33 PM   #6
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263

Original Poster
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Continuing story...

With the (apparently) early release of FreeBSD 10.2 I decided to bring my 10.1 system up to date.

Starting with...

Code:
freebsd-update -r 10.2-RELEASE upgrade
freebsd-update install
...and the necessary reboot steps, and following with...

Code:
portsnap fetch
portsnap update

portmaster -an >new_ports_list
...then working through subsets of the resulting list(*) with...

Code:
portmaster -gd PORT_NAME
... I am now running a fully updated FreeBSD 10.2 installation!

The most exciting thing along the way was getting to the end of the list!


(* I know, I could have done them all at once, but I prefer to build them incrementally.)
 
Old 08-27-2015, 09:54 AM   #7
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,727

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
Any reason why you're building ports from source rather than just installing packages?

Last edited by cynwulf; 08-27-2015 at 09:55 AM.
 
Old 08-28-2015, 02:31 AM   #8
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263

Original Poster
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Quote:
Originally Posted by cynwulf View Post
Any reason why you're building ports from source rather than just installing packages?
It is just the best fit with my own methods, habits, requirements, personality quirks, whatever...

I try to manage my Slackware systems, archives and even hardware with a mindset that decouples dependence on outside sources as much as possible. A major component of the resulting methods is that all software that enters my realm beyond the base OS enters as source and is built and packaged on my own machines, and added to my own versioned repos - only then is it installed for use. This guarantees that I have the sources for everything I use, that I have successfully built it at least once, and that I control tested and self-maintained packages... even without the proverbial doomsday scenario, this has proven to result in excellent stability and fewest surprises.

I have tried to incorporate my FreeBSD system(s) into that existing build-archive system, and the ports system is a pretty good fit! Additionally, I am trying to learn the FreeBSD system to a level of confidence similar to that which I have with my Slackware systems - building and maintaining this way gives me best exposure for learning as well. If/when I support more FreeBSD machines, I will then update and install them from my own ports generated package archive.

Which is really just to say, it is how I prefer to do things...
 
Old 08-29-2015, 09:46 AM   #9
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Debian, Slackware
Posts: 7,342

Rep: Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746
Quote:
Originally Posted by astrogeek View Post
Which is really just to say, it is how I prefer to do things...
Your methodology looks sound to me.
 
Old 08-29-2015, 01:52 PM   #10
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,727

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
Quote:
Originally Posted by astrogeek View Post
Additionally, I am trying to learn the FreeBSD system to a level of confidence similar to that which I have with my Slackware systems - building and maintaining this way gives me best exposure for learning as well. If/when I support more FreeBSD machines, I will then update and install them from my own ports generated package archive.
As a learning exercise, building from ports is useful - in fact it's quite important. Eventually when you're past that stage, but if you want to apply some patch or change build flags, that's useful. If you're just rebuilding exactly the same thing which could be fetched with pkg - it's not that useful. I have a feeling that eventually your methodology will fall down - maybe during one of those long drawn out rebuilds of qt4, firefox or llvm... but it's all part of the learning experience.

 
Old 09-14-2015, 05:22 PM   #11
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Debian, Slackware
Posts: 7,342

Rep: Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746Reputation: 3746
Quote:
Originally Posted by cynwulf View Post
I have a feeling that eventually your methodology will fall down - maybe during one of those long drawn out rebuilds of qt4, firefox or llvm... but it's all part of the learning experience.
Like you I prefer to install packages on the BSDs, but, each to his/her own. Whatever works.
 
Old 09-16-2015, 12:36 AM   #12
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263

Original Poster
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Quote:
Originally Posted by cynwulf View Post
As a learning exercise, building from ports is useful - in fact it's quite important. Eventually when you're past that stage, but if you want to apply some patch or change build flags, that's useful. If you're just rebuilding exactly the same thing which could be fetched with pkg - it's not that useful. I have a feeling that eventually your methodology will fall down - maybe during one of those long drawn out rebuilds of qt4, firefox or llvm... but it's all part of the learning experience.

Sorry to be so long replying, your comments are read and appreciated.

I have thought through my own methodology looking for some reason that you think it might fall down, but have not seen anything obvious, at least to me. Build times are not really a concern, and having built both firefox and llvm at least twice during my updates, I am curious why you think a ports build based management methodology might fail specifically during a longer build?

Also, as mentioned in earlier posts, I archive the source of all addon packages as a requirement of my methods. Building a port as opposed to installing from pre-built ports packages guarantees the archive is updated, and source and port build scripts are viable - kind of like verifying a backup. If my build is the same as the pre-built package in the end, I see only additional advantage (validation and local archive) and no downside (same package) other than my own involvment in the process.

But I will allow I may be missing something, so please elaborate your own thoughts on where or why or when it might fail.

I would also add that as an exercise, building from ports regularly has the advantage of keeping the wetware memory refreshed. That is in fact one goal of the ongoing exercise, and of growing importance to, whats-his-name behind the keyboard!
 
Old 09-16-2015, 08:01 AM   #13
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,727

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
Quote:
Originally Posted by astrogeek View Post
Build times are not really a concern, and having built both firefox and llvm at least twice during my updates, I am curious why you think a ports build based management methodology might fail specifically during a longer build?
If you have the time, the energy and the will to continually rebuild ports then of course there's no issue. But if "pkg install qt4" or "pkg upgrade" achieves the same end, then one would still have to ask "why?". If the answer is still only what amounts to "because I want to", then there's not really much more to say. By the way - you are free to do exactly as you please with your system, I'm merely commenting and if you went to the FreeBSD forums or daemonforums.org or the mailing lists, you'd probably be faced with the same questions. You're a new user I believe? So those annoying questions will be much more common.

If you were doing what you're doing on OpenBSD, then the questions would be more frequent and even more annoying.

For example - as an OpenBSD -stable user, the only time I would rebuild ports is if there had been some new patches to some software I use (OpenBSD does not provide binary updates). So some_port which requires some_big_port which has not been updated itself in order to build is going to involve pulling in the source for said port and building that first before building some_port. The result is that, after hours building some_big_port, which is only required to build some_port, what exactly did I achieve over just installing some_big_port first as a package (and removing it afterwards if no longer required)? To avoid fetching and building ports which already exist as packages I set a config option to ensure that packages are pulled in and installed wherever they exist to meet dependencies (I can't remember if FreeBSD has something similar as it's years since I built from ports on FreeBSD).

The ports tree includes a set of tools and scripts, once you've run two or three commands and walked away and left it to rebuild all the updated ports, there is not much left to learn unless you actually want to get into porting your own software. Despite what some fanbois would have you believe, you don't really need special skills to build from ports, this is because, like the Slackbuild scripts you're more familiar with, someone else has already done all of the hard work. The ports tree is provided as a means to build packages for those that need it (i.e those who want to build different flavours, etc), it does not even have to be installed in bog standard system.

Also I suspect that your base system isn't built from source but installed from binary installation sets?

Last edited by cynwulf; 09-16-2015 at 08:03 AM.
 
Old 09-17-2015, 02:52 AM   #14
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263

Original Poster
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Quote:
Originally Posted by cynwulf View Post
If you have the time, the energy and the will to continually rebuild ports then of course there's no issue. But if "pkg install qt4" or "pkg upgrade" achieves the same end, then one would still have to ask "why?".
Well, as I mentioned in previous posts, in particular post #8 in this thread, the reason is to fit into the pattern that I use to maintain my local Slackware (and other) archives.

Not because I think FreeBSD is "like" Slackware, but because the pattern (or method or spec) is proven and successful, and meets my end requirements. It is not just about updating my shiny new FreeBSD box, although the single box has been the primary focus as I integrate FreeBSD into my realm.

As also mentioned in a previous post, the ports system is a very good fit within my existing methods, which I suspect is at least partly due to the foundations of both being drawn from other best practices among developers, packagers and sysadmins over time and industry sources.

Not to labor the point, but for completeness for anyone following this discussion, I outlined my overall plan and requirements in another thread when my FreeBSD adoption adventure began. Two major points unresolved at that time were PXE installs of FreeBSD and integration within my source/package archive system. I resolved the PXE problem a few months later and I now fully support FreeBSD installs, and updates, from my own PXE servers. My own use of the ports system is essentially an input to that overall local FreeBSD support system.

Quote:
Originally Posted by cynwulf View Post
If the answer is still only what amounts to "because I want to", then there's not really much more to say.
Well, it is "because I want to", but not without some solid reasons for doing so, and benefits received.

Quote:
Originally Posted by cynwulf View Post
By the way - you are free to do exactly as you please with your system, I'm merely commenting and if you went to the FreeBSD forums or daemonforums.org or the mailing lists, you'd probably be faced with the same questions. You're a new user I believe? So those annoying questions will be much more common.
If you mean the questions like "why do it that way?", I do not find the questions annoying. My apology if I have given that impression. And I hope I do not seem argumentative either - not my intent! If you see some flaw in my system as applied to FreeBSD I definitely want to understand what it is!

I am a new FreeBSD user, approx. 15 months now, but definitely not a new computing user, developer, sysadmin, having worn many hats in many setting over many years.

Quote:
Originally Posted by cynwulf View Post
If you were doing what you're doing on OpenBSD, then the questions would be more frequent and even more annoying.
...
The ports tree includes a set of tools and scripts, once you've run two or three commands and walked away and left it to rebuild all the updated ports, there is not much left to learn unless you actually want to get into porting your own software. Despite what some fanbois would have you believe, you don't really need special skills to build from ports, this is because, like the Slackbuild scripts you're more familiar with, someone else has already done all of the hard work. The ports tree is provided as a means to build packages for those that need it (i.e those who want to build different flavours, etc), it does not even have to be installed in bog standard system.
Indeed, the ports tree includes an excellent set of very well maintained tools and scripts! I love, and am somewhat amazed that it is essentially all done with makefiles! Oddly enough, I can get my head around that!

But I would be very surprised, and a little disappointed if I found that the developers and maintainers of those tools did not expect me to use them as best suited my own needs! I am not abusing them or mangling them or trying to get them to do something they were not intended to do - I am indeed getting some very good use out of their basic functionality!

It is, in fact, a validation of those tools and their documentation that I have not found it necessary to pester them in their forums with my own annoying questions!

And I had forgotten (having not yet actually done so), I do indeed intend to port at least two applications using ports compliant builds. I do the same with my own Slackbuild scripts for these and will eventually add them to my FreeBSD archives... just haven't needed them under FreeBSD yet.

Quote:
Originally Posted by cynwulf View Post
Also I suspect that your base system isn't built from source but installed from binary installation sets?
Yes the base system is installed from binary and updated from the patches, which also are synched to my local repo. Same for my Slackware systems.

To say again, the point is not to build everything from source. The point is optimum sustainability of existing state at any given time, with minimum, optimally zero reliance on external sources. That has served me well for a very long time, I am happy to add FreeBSD into the mix.

Anyway, sorry to be so long winded, and your comments appreciated! Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm using freebsd-update with FreeBSD - should I use env_keep in sudoers? pr_deltoid *BSD 1 06-20-2010 10:57 PM
No sound after update packages....(including update alsa) Mathsniper Debian 8 11-22-2006 04:43 AM
FreeBSD install manual error??? Southpaw76 *BSD 2 05-21-2006 04:27 PM
compiling source packages (including manual changes) michapma Debian 1 12-18-2005 04:06 PM
Can't update FreeBSD Ports Tree Temujin_12 *BSD 12 06-11-2005 09:04 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 10:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration