LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Can't connect the internet in freebsd (http://www.linuxquestions.org/questions/%2Absd-17/cant-connect-the-internet-in-freebsd-350637/)

jm0624 08-06-2005 03:03 PM

Can't connect the internet in freebsd
 
my freebsd is 5.4,I have tried many ways to connect ,but failed,
ppp does not works,even if I edit it like the sample and the sample from many forums,except the ppp,how can i connect the internet ,i am using ADSL to connect,when i use debian,it works very well,it is pppoe ,but in bsd,it can't,
....
and is there any other tools to use to connect the internet?
thanks...

Arisna 08-08-2005 12:30 AM

My only suggestion would be entering the sysinstall utility (as root), navigating to the network interfaces section, hitting enter when you have your card selected, and attempting DHCP configuration.

N|k0N 08-26-2005 12:33 AM

Thanks a lot for mind jog, i was recently installf FreeBSD myself and i was sitting here wondering why i could not get online. Not realising to myself that i kept setting up bfe0 using the livecd and forgetting it erases everytime that the system restarts.

cnjohnson 08-28-2005 04:14 PM

Re: Can't connect the internet in freebsd
 
Quote:

Originally posted by jm0624
my freebsd is 5.4,I have tried many ways to connect ,but failed,
ppp does not works,even if I edit it like the sample and the sample from many forums,except the ppp,how can i connect the internet ,i am using ADSL to connect,when i use debian,it works very well,it is pppoe ,but in bsd,it can't,
....
and is there any other tools to use to connect the internet?
thanks...

I solved the problem by buying a small netgear switch and connecting my DSL modem to the switch. I set the internal IP address of the switch to 192.168.0.1. Then I added the following lines to my /etc/rc.conf file:

defaultrouter="192.168.0.1"
ifconfig_fxp0="inet 192.168.0.4 netmask 255.255.255.0"

(My network interface is fxp0).

This worked for me.

Cheers--
Charles


All times are GMT -5. The time now is 10:54 AM.