LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 09-28-2007, 02:27 AM   #1
saivinob
LQ Newbie
 
Registered: Aug 2007
Location: Bangalore, India
Distribution: Debian Etch, CentOS 5, FreeBSD 6.2
Posts: 11

Rep: Reputation: 0
Audio problem in FreeBSD 6.2


Hi,
I'm not able to enable sound on my FreeBSD 6.2. The error message when I click on the speaker icon is:
[HTML]The volume control did not find any elements and/or devices to control. This means either that you don'thave the right GStreamer plugins installed, or that you don't have a sound card configured.[/HTML]
My motherboard is Asus K8V-VM with southbridge VT8233A. I tried,
Code:
kldload snd_via8233
When it didnot work I tried,
Code:
kldload snd_driver
cat /dev/sndstat yields just,
[HTML]
#cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices
[/HTML]
The motherboard uses Realtek ALC660 driver I believe...

Any idea how I can solve this problem?
 
Old 10-03-2007, 02:43 AM   #2
saivinob
LQ Newbie
 
Registered: Aug 2007
Location: Bangalore, India
Distribution: Debian Etch, CentOS 5, FreeBSD 6.2
Posts: 11

Original Poster
Rep: Reputation: 0
Problem solved

Hi all,

The problem is solved.

The actual chipset was not VT8233A but VT8237A. Also, I was informed that VT8237 and VT8237A are not the same. Thats the reason why 'kldload snd_via8233' was not able to solve the issue.

The actual driver needed was 'snd_hda'. I got the precompiled module from http://people.freebsd.org/~ariff/lowlatency.

It was also said that this module was not currently available in FreeBSD -RELEASE and would be available if we upgrade to FreeBSD -STABLE.

Hope this thread may help somebody.

Regards,
SV
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
audio problem in FreeBSD phinux *BSD 2 06-29-2006 09:15 PM
M-audio audiophile 2496 and freebsd jasone *BSD 2 12-19-2005 05:32 AM
Intel ICH6 Audio && FreeBSD 6.0 Beta 5 taylor_venable *BSD 13 10-10-2005 06:07 PM
How to play Audio/ Video CD on FreeBSD selvyn Linux - General 2 02-25-2004 08:47 PM
VT82C686A (Audio Devices) on FreeBSD remide *BSD 1 09-14-2003 04:18 PM


All times are GMT -5. The time now is 06:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration