LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Linux Answers > Hardware
User Name
Password

Notices

By vangelis at 2006-06-01 13:18
I had a problem along many others when purchased my new pc. I purchased
an AMD64 +3200 processor and since ofcourse I wanted to install a 64bit
linux distribution.

My dsl modem was working perfectly with x86 suse 10.1 (and 10 and 9.3)
but when I installed the 64bit version.
It wasn't recognized from Suse.

From a short search I found out that two modules were missing, although
in x86 were loaded, in x86_64 were not.

So let's start.
Since kernels later than 2.6.10 include the driver for this modem I had
to do the below:

Install from YaST the kernel sources, gcc, and make so as to compile the modules. Optionally you can install kinternet so as to connect with just a click.

In a root terminal do:

Code:
#cd /usr/src/linux

#make mrproper
#make cloneconfig
That command generates the configuration for your kernel and your
modules as is right now.
And since I didn't want to mess with my kernel I changed only one
option.

Code:
#vim .config
search for a commented line saying
Code:
#CONFIG_ATM
delete the # character and write 
CONFIG_ATM=m
that means it will be compiled as a module.

Save the file

Next command

Code:
#make modules_prepare
Here it will find that something different is in the config file and ask
you about many drivers.
On every question answer N - you don't need most of them they are
experimental and may make your system unstable(as mine was first time I
did it).

You only need 2 modules.
USB_UEAGLE and PPPOATM
when you see those two answer m and when it's finished
do a

Code:
#make modules_install
That's it now. Since you have a 64bit processor, it means it's fast and it won't take long.

I suggest you to now run it with X loaded. It would be faster, just give the command

Code:
#init 3
do all the above and after that just a '#init 5' (without the quotes) is enough to load X.

When everything finishes I followed the firmware installation from the eagle-usb project
http://atm.eagle-usb.org/wakka.php?wiki=UeagleAtmDoc

You have the kernel modules so you only need the firmware data.
Just grab the file from
http://eagle-usb.org/ueagle-atm/non-...ata-1.1.tar.gz

extract it in a temp directory and enter it

create a dir in /lib/firmware named ueagle-atm

Code:
user@penguin:~/temp/ueagle-data-1.1#mkdir /lib/firmware/ueagle-atm
and copy everything from the extracted directopy

Code:
user@penguin:~/temp/ueagle-data-1.1#cp -a *
/lib/firmware/ueagle-atm

unplug and replug the modem.
Check with dmesg command for the lines saying

Code:
usb 1-2: [ueagle-atm] modem operational 
usb 1-2: [ueagle-atm] ATU-R firmware version : 43e2ead7
it should blink for a while also.

Now only kinternet needs to be setup so as to make the connection with just a single click!
Ofcourse it needs to be installed first

At YaST do the following.

Network Devices --> DSL
(tab DSL devices) --> Add
PPP Mode --> PPP over ATM
VPI/VCI --> 8.35 (mine worked like that, I 've read that you can get it from your ISP, but I don't know if the phone support even knows that, at least here in Greece)

Device Activation --> Here read the options it gives, choose everything that suits you.
User Controlled --> Checked (if you want to use kinternet to connect)

Next --> Choose your provider or create one if not in list.

Finish.

Now fire up kinternet and click it.
Happy safe surfing!

Feel free to contact me for any mistakes above or questions!


  



All times are GMT -5. The time now is 11:41 AM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration